Jump to content

We have updated TG007.net. If you notice any problems please let us know.

  • Announcements

    • err0r

      Updates

      Please let us know if you notice any errors with the new theme.
Sign in to follow this  
megg

Moschino Problems

Recommended Posts

; -- Webchat joiner.

 

alias Webchat_Join {alias Webchat_Join {

var %Channel = $$?=" $+ $Eval($Lang(m_webroom), 2) $+ "

 

if (%Channel) {

Web_Join $Chan_Encode(%Channel) %Channel

}

}

 

alias Chan_Encode {

var %C = $$1

 

%C = $Replace(%C, $Chr(32), \ B)

%C = $Replace(%C, \, $(%5c, ), ; , $(%3b, ))

 

return $(%25%23, ) $+ %C

}

 

alias Web_Join {

var %Encoded = $$1, %Decoded = $$2

 

hadd -m %Decoded CHANNEL %Encoded

 

if ($Window(@webchat. $+ %Decoded)) window -c @webchat. $+ %Decoded

 

window @webchat. $+ %Decoded

 

dialog -m Webchat. $+ %Decoded Webchat

}

 

dialog Webchat {

title "Webchat"

size -1 -1 600 480

}

 

alias Webchat_Callback return

 

on *:DIALOG:Webchat.*:INIT:0:{

var %D = $Dname, %Channel = $Hget($Gettok(%D, 2, 46), CHANNEL)

 

dcx Mark %D Webchat_Callback

 

xdialog -b %D +

 

xdialog -c %D 100 webctrl 0 0 640 480

xdid -n %D 100 $+($MainSettings(CONNECTION, CHANLINK), /chatui.aspx?rm=, %Channel)

 

xdialog -l %D root $Chr(9) +pv 0 0 0 0

xdialog -l %D cell root $Chr(9) +li 100 10 0 0

 

.timer 1 0 xdialog -l %D update

.timer 1 0 xdock -c $Dialog(%D).hwnd +s $Window(@WEBCHAT. $+ $Gettok(%D, 2, 46)).hwnd

}

Share this post


Link to post
Share on other sites

did you change CHANLINK in global settings from www.buzzen.net to chat.buzzen.com ? Also the dcx webctrl may not work with updated webchat javascript as it uses old ie rendering.

Share this post


Link to post
Share on other sites

hummmmmmmmm I am using the 217kb dcx.dll

could I have a conflict with any other dll ?

also I have tried the updated dcx.dll but

I then get two windows and that's it but no D_ERROR xdock

Edited by plugster

Share this post


Link to post
Share on other sites

depends on the dcx and mirc versions... there is a dcx version for mirc 6.35 and lower and one for newer mirc..must be using the right dcx.. if there is no xdock it sounds like you might not have the xdock alias loaded.

Share this post


Link to post
Share on other sites

xdock alias should be in moschino[flashbuzzen] file.. make sure there are no bracket mismatches in your remote files.

Share this post


Link to post
Share on other sites

I have checked line by line in moschino and it is the same as the other ones I have

I even tried other scripts running moschino and I still get the same thing

in a test room I can get the webchat to dock but it hangs on loading the test room

but if I try to open webchat for a different room that is when I get the D_ERROR xdock

I am totally lost on this one or am I missing an install on my comp ?

frustration is one way to put it.

Share this post


Link to post
Share on other sites

ok I think I have figgered out what is wrong but not a clue how to fix it.

from what I see it is trying to load in compatability mode

even though both 64 and 32bit ie's are not set that way

so any sugestions on how to fix that will be gladly taken

so the webchat can work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×